Re: DEB Package?

Bitcointalk

2010-02-12 15:57:37 UTC - Original Post
If you want, I can provide you with a precompiled binary.

Am I missing something?  Is there something wrong with the 32-bit linux precompiled binary on bitcoin.org?

The bitcoin binary in the distribution static links the wxWidgets library, and its shared links (openssl and GTK) are included in Ubuntu, so it can run without needing to be a .deb to pull down dependencies.

Since we're upgrading to wxWidgets 2.9.0 for UTF-8, which doesn't have a DEB package yet, we'll continue to need to static link it.