BitcoinTalk
Building Bitcoin 0.3

View Satoshi only

External link

I tried building it myself but it didn't compile.
Which ports did you use?
I tried with wxgtk28-unicode and db42-4.2.52_5 & db50-5.0.21.0
Here the latest attempt:
nagilum@cakebox ~/src > uname -a
FreeBSD cakebox.tis 8.1-PRERELEASE FreeBSD 8.1-PRERELEASE #0: Tue Jun 29 22:25:46 CEST 2010     root@cakebox.tis:/usr/obj/export/src/sys/net5501  i386
nagilum@cakebox ~/src > gmake -f makefile.unix
g++45 -c -O2 -Wno-invalid-offsetof -Wformat -g -D__WXDEBUG__ -D__WXGTK__ -DNOPCH -I"/usr/include" -I"/usr/local/include" -I"/usr/local/include/wx-2.8" -I"/usr/local/lib/wx/include/gtk2-unicode-release-2.8" -I"/usr/local/include/db50" -o headers.h.gch headers.h
In file included from headers.h:108:0:
ui.h:13:142: error: default argument for 'const wxString& caption' has type 'const char [8]'
ui.h: In function 'int MyMessageBox(const wxString&, const wxString&, int, wxWindow*, int, int)':
ui.h:19:51: error: no matching function for call to 'std::basic_string<char>::basic_string(const wxString&)'
/usr/local/lib/gcc45/include/c++/bits/basic_string.tcc:219:5: note: candidates are: std::basic_string<_CharT, _Traits, _Alloc>::basic_string(std::basic_string<_CharT, _Traits, _Alloc>::size_type, _CharT, const _Alloc&) [with _CharT = char, _Traits = std::char_traits<char>, _Alloc = std::allocator<char>, std::basic_string<_CharT, _Traits, _Alloc>::size_type = unsigned int]
/usr/local/lib/gcc45/include/c++/bits/basic_string.tcc:212:5: note:                 std::basic_string<_CharT, _Traits, _Alloc>::basic_string(const _CharT*, const _Alloc&) [with _CharT = char, _Traits = std::char_traits<char>, _Alloc = std::allocator<char>]
...
Looks like your wxWidgets and STL - you should compile your own wxWidgets from the 2.9 release.

Use something like this to configure it and adjust the reference paths in your makefile.unix

Quote
mkdir buildgtk
cd buildgtk
../configure --prefix=/home/my_user/bitcoin/deps \
--with-gtk \
--disable-shared \
--disable-debug_flag \
--enable-stl \
--enable-utf8 \
--with-libjpeg=builtin \
--with-libpng=builtin \
--withregex=builtin \
--with-libtiff=builtin \
--with-zlib=builtin \
--withexpat=builtin

It doesn't work with wxWidgets 2.8, it needs wxWidgets 2.9.  Unfortunately, there isn't a Debian package of wxWidgets 2.9 yet.